The Advantage Database Server update for has been released inculding

  • Support for the latest version of Delphi - XE7.
  • Support for latest version of Vulcan - Vulcan.NET build 3.0.303.
  • Advantage .NET dataprovider installation now works on destination machines with Visual Studio 2012.
  • Support for Entity Framework 5 is now functional(**).
  • Security Enhancement #1: Upgrade FIPS-compliant OpenSSL libraries and header files to OpenSSL version 0.9.8zb to incorporate recent security fixes.
  • Security Enhancement #2: Disable SSLv3 (and SSLv2) for communication between ADS and Advantage Client Engine (ACE) to cover POODLE attack vulnerability.
  • Critical ADS bug fixes for customer escalations reported since 11.1 SP20.

Downloads available here: Advantage Release 11.1

(**) For generating database schema from entity model on a machine with Visual Studio 2012, please download the following file and copy it in the DBGen folder under Entity Framework Tools (e.g. C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE\Extensions\Microsoft\Entity Framework Tools\DBGen )

asked 01 Dec '14, 03:42

Parag%20Mahadane's gravatar image

Parag Mahadane
accept rate: 4%

edited 01 Dec '14, 04:03

(02 Dec '14, 13:02) Jack


We downloaded the 64-bit version of server (from the above location) and tested it on a 64-bit machine with windows server 2003. It is working fine for us.

We also tried installing the same executable on a 32-bit machine and this does not work as expected. We get the following error -

-Error 5 running command setup.exe

Could you please retry?


ADS Engineering Team

(02 Dec '14, 22:12) Vinay Santurkar

Seems like it's working now, not sure why I encountered problems yesterday.

(03 Dec '14, 13:41) Jack

That's good to hear, Jack.

(03 Dec '14, 22:21) Vinay Santurkar

The following items are being worked upon:

  • Support for Visual Studio 2013 with Entity Framework 6
  • Certification of ADS on Windows Server 2012 R2 and Windows 8.1

Announcements will follow on the devzone.


answered 01 Dec '14, 03:47

Parag%20Mahadane's gravatar image

Parag Mahadane
accept rate: 4%

I do not understand if this version supports now Windows Server 2012 R2 Standard. Does it or not ? And what about Windows Server 2008 R2 Standard ? Thanks

(01 Dec '14, 04:18) lbidi


This version does NOT support Windows Server 2012 R2 standard. We are in the process of certifying this platform. We will update you shortly after the certification is completed.

Windows Server 2008 R2 is already supported.



(01 Dec '14, 06:57) Vinay Santurkar

Hello Team Advantage,

what is: Critical ADS bug fixes for customer escalations reported since 11.1 SP20.

Thank's for information Matthias Schlegel


answered 02 Dec '14, 02:22

matthias%20schlegel's gravatar image

matthias sch...
accept rate: 0%

This Service Update of the Advantage Database Server addresses the following issues:

1.Fixed an issue where a non-adssys user would recieve a 7087 error opening a Data Dictionary Link and the CheckFreeTablesAccess connection string was set to TRUE.

2.Incorrect logic that could result in a 9111 error when using FETCH_UNKNOWN OR FETCH_REVERSE as a fetch direction of a ResultSet using JDBC driver.

(02 Dec '14, 03:27) Vinay Santurkar

This Service Update of the Advantage Database Server addresses the following issues:

3.Server failure caused during execution of SHOW PLAN on a statement with IN operator and a subquery in it.

4.Bug in server logic which resulted in a 2146 error when executing a query twice that includes a WHERE and ORDER BY clause with numeric fields and with indexes created in particular order.

(02 Dec '14, 03:28) Vinay Santurkar

Since last week I upgraded my Advantage Database Server to version Before that I used for my development the with FIPS. To test if my software is FIPS complaint.

However I cannot find the upgraded FIPS-compliant OpenSSL libraries version 0.9.8zb (libeay32.dll, ssleay32.dll and openssl.exe) for version

I downloaded the file from SAP support site but this hold the old version. The include only holds the (libeay32.dll and ssleay32.dll). Openssl.exe is missing which is needed to create a self signed certificate.

On The is not present.

When starting ADS Server as a service with the FIPS modules libeay32.dll and ssleay32.dll supported for It gives an 7165 error.

Where can I download the correct (libeay32.dll, ssleay32.dll and openssl.exe) for version


answered 11 May '15, 11:50

Andromeda%20XS's gravatar image

Andromeda XS
accept rate: 0%

Does ADS now support Windows 2012 R2? From the above it reads as if support for 2012 R2 is not available yet, however I found another SAP document on the web where it says from R2 is supported. What is the case?


answered 12 May '15, 07:22

Stephan%20Leiwering's gravatar image

Stephan Leiw...
accept rate: 19%


answered 12 May '15, 14:18

Andromeda%20XS's gravatar image

Andromeda XS
accept rate: 0%

I am just wondering why it is not listed in the announcement of that release nor in this post as an update to Parag's post from 01 Dec 2014.

(12 May '15, 23:05) Stephan Leiw...
Your answer to the original question.
If responding to a request for additional information, please edit the question or use the comment functionality.
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported



Asked: 01 Dec '14, 03:42

Seen: 8,343 times

Last updated: 12 May '15, 23:05

Advantage Developer Zone Contact Us Privacy Policy Copyright Info

Powered by Advantage Database Server and OSQA
Disclaimer: Opinions expressed here are those of the poster and do not necessarily reflect the views of the company.