Hi,

I have a Suse Linux Enterprise Server 11 with Novell Open Workgroup Extension. I installed ADs12 and the daemon is running. Server IP is 192.168.0.201

Client has ARC installed and I can connect with \192.168.0.201:6262 with the remote server info. I see connections and installation information. So adsd must run.

If I open the file browser on the server console and go to file system, I see a folder "Advantage" which contains my databases. If I go to "root" then I see a folder ads which I have created and copied some databases to this folder On console "cd \" followed by ls lists the ads dir A cd /Advantage changes to the Advantage Dir

I used chmod 777 -r for /Advantage and ads. So I assume that daemon should have rights to these folders.

I have root\ads\bg_vertrieb\bg_vertrieb.ADD and File System\Advantage\bg_vertrieb\bg_vertrieb.ADD

I tried all? combinations of a connection string to open a table or a dictionary without success. Table: connection is active but no table is listed. Regardless if I just add a dir or include table name

If I open the dictionary I get asked for the password and then I get an Error 5004

What is my mistake except the fact that I´m not a linux expert?

What would be a correct connection string? I´m sure it´s just a minor change and it will run. But how....

Björn

asked 18 May '16, 16:56

Bjoern's gravatar image

Bjoern
16112
accept rate: 0%

edited 19 May '16, 02:53

Jens%20M%C3%BChlenhoff's gravatar image

Jens Mühlenhoff
1.3k51037


Some ideas:

  • ARC32 only lists tables in the connection repository if it also has access to the data directory via SMB (Windows / Samba file share).

  • Linux is case sensitive. There is an ads.conf (not ads.ini!) setting called LOWERCASE_ALL_PATHS which can help here.

  • When the "ignore rights" setting is set to false a 5004 error may occur, because of the missing direct access (see above)

See also 5004 online help:

http://devzone.advantagedatabase.com/dz/webhelp/Advantage12/error_5004_ae_file_not_found.htm

Either the Advantage Client Engine could not find the specified file, or you do not have sufficient rights to access the file. An incorrect path may cause this error. To identify an incorrect path, change the Advantage Database Server security method to "Ignore Rights" in your application. For example, for the TDataSet Descendant, set the AdsTableOptions' AdsRightsCheck property to False. When restarted, the application will generate a 7008 error, which will be logged in the Advantage error log file. Verify that the path in error log's "filename" column is correct.

Note If connecting to a Linux server using a UNC path, you may get this error if you have Advantage Rights Checking enabled. The Linux client cannot resolve the UNC path to check for file existence, so rights checking should be disabled. Also, if you are connecting to any server with a connection path that contains an IP address and/or port number, you will get this error. See Database Security for client-specific directions on enabling/disabling Advantage Rights Checking.

link

answered 19 May '16, 02:51

Jens%20M%C3%BChlenhoff's gravatar image

Jens Mühlenhoff
1.3k51037
accept rate: 18%

edited 19 May '16, 02:55

Hi Jens,

1) means I can´t open a single table with arc if it´s located on a linux server with remote mode? I have a samba share to /Advantage.

If I browse the path and open in local mode then it works. If I change it to remote I get a 6420 error. How can I open this file in remote mode? That´s my problem that I don´t understand how I have to type in the connection string. Or is it just not possible to open a adt file in remote mode?

AdsRightsCheck property in ARC is set to False by default.

LOWERCASE_ALL_PATHS=1 is set in ads.conf

It might be possible that my path is not correct. But what would be the correct path?

(19 May '16, 14:24) Bjoern

You can open them just fine, it just wont list them (which means when you expand your connection in the repository tree, you won't see any tables).

This is only for free connections, if you are using a dictionary (which you apparently are) this is not a problem.

(20 May '16, 05:00) Jens Mühlenhoff

6420 means that you can't connect to the server at all. So server and or port is wrong.

(20 May '16, 05:02) Jens Mühlenhoff

Regarding the path you could try to set up a server side alias configuration: http://devzone.advantagedatabase.com/dz/webhelp/Advantage12/master_server_side_aliases.htm

(20 May '16, 05:05) Jens Mühlenhoff

I think that the adsserver.ini for server side aliases has to be in the /var/log/advantage directory (or whereever your adsd writes its log files)

(20 May '16, 05:07) Jens Mühlenhoff

BTW: If you want official support you should better post in the SAP SCN at http://scn.sap.com/community/ads

(20 May '16, 05:08) Jens Mühlenhoff
showing 5 of 6 show 1 more comments

Hello Jens,

I try to setup a server side alias.

I re-installed the ADS meanwhile, used my SAMBA share as data directory and now I can´t access my share any more. So it seams that I used the correct path during installation. But I still can´t connect.

If /Advantage is supported as data directoy I would assume that

  • \\192.168.0.1:6262\Advantage\bg_vertieb.add
  • \\192.168.0.1:6262\Advantage\robinson.adt

would be correct to open a dictionay or table which is stored in this directory. For the table I just get a connect but no table listed and the dictionary returns 5004 Are these paths coreect?

Next I tried to create a new table with ARC. But here´s the same problem. ARC doesn´t find the path if I use the IP inside. Maybe I need a samba share in this case.

I´m sure that it works in a specific way which I still did not find. Sure that the WIndows version would have been worked for me after 5 minutes.

link

answered 27 May '16, 02:33

Bjoern's gravatar image

Bjoern
16112
accept rate: 0%

edited 27 May '16, 03:16

Jens%20M%C3%BChlenhoff's gravatar image

Jens Mühlenhoff
1.3k51037

Update from me.

new installation to /addata

still not possible to open bg_vertrieb.ADD. after changing all names to lower case I was able to open add and table inside add which had before a upper case extension (.ADT). Get opened after changing it to lower case

link

answered 01 Jun '16, 15:11

Bjoern's gravatar image

Bjoern
16112
accept rate: 0%

An idea: Have you tried creating a completly new dictionary on the Linux server using ARC?

(02 Jun '16, 04:18) Jens Mühlenhoff

Latest result....

//192.168.0.201:6262/addate/bg_vertrieb/bg_vertrieb.add let me open the data dictionary. Works for othe ADD also.

But if I try to open single ADT I get error 7077: The Advantage Data Dictionary cannot be opend. Why ADD? Want to open single table. How can I open single table robinson.adt in //192.168.0.201:6262//addata/robinson? Or mandanten.adt in //192.168.0.201:6262/addate/bg_vertrieb/mandant

link

answered 10 Jun '16, 14:58

Bjoern's gravatar image

Bjoern
16112
accept rate: 0%

Does single table mean "free table" or "table created in dictionary"?

(13 Jun '16, 04:58) Jens Mühlenhoff

Normally you would connect to the directory containing free tables and then you should be able to query them using "select * from [tablename]".

(13 Jun '16, 04:59) Jens Mühlenhoff

It´s a free table without a dictionary

I thought I can open a table with its name using the connection Repository. But that works only for local mode

Creating a remote connection to the dictionary and then open the SQL Utility enables me to start a query.

Ok it seems that I got it now...

link

answered 13 Jun '16, 13:36

Bjoern's gravatar image

Bjoern
16112
accept rate: 0%

Your answer to the original question.
If responding to a request for additional information, please edit the question or use the comment functionality.
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×39
×29
×14
×2
×1

Asked: 18 May '16, 16:56

Seen: 2,237 times

Last updated: 13 Jun '16, 13:36

Advantage Developer Zone Contact Us Privacy Policy Copyright Info


Powered by Advantage Database Server and OSQA
Disclaimer: Opinions expressed here are those of the poster and do not necessarily reflect the views of the company.