2
1

Greetings.

XE6 has been out for almost two months now. The only reason I'm still stuck with XE5 is that the advantage components have last been updated in September 2013. Luckily, they come with source, located in C:\Program Files (x86)\Advantage 11.10\TDataset\Source

I have no idea what to do with it- I can compile both packages fine but the installation fails: It states that rtl190.bpl is nowhere to be found. Hardly surprising, with XE6, it's rtl200.bpl.

I fully understand that XE6 is not officially supported. But I can't be the only one using XE6 and Advantage components?

asked 06 Jun '14, 05:52

Overclock%20Your%20Breakfast's gravatar image

Overclock Yo...
1157916
accept rate: 0%


I have heard multiple reports of customers successfully compiling (and using) the TDataSet for XE6 based on the source we ship, so I'm sure you're not the only one. That said, this is the first time I've seen this particular error, so I think it should be solvable.

We don't expressly use any particular version of the rtl library. Both the Design-time and Run-time DPK files list the RTL in the requires section, and the compiler resolves that to a specific bpl dependence. My guess is that you're trying to re-use the XE5 DPK/dproj files in XE6, which still contain references to the old compiler. (Which is probably where the specific reference to rtl190 is coming from.) You need to create a new XE6-specific DPK files (and let Delphi automatically generate the dproj file from the DPK).

This article has a good overview of the specific process you should use to build XE6 packages from the source. (Note: The article talks about adding support for XE2 based on our package files for XE. The information is still valid, but you'll need to conceptually substitute XE6 for XE2 and XE5 for XE in the post.)

link

answered 06 Jun '14, 08:09

Jed%20Thomet's gravatar image

Jed Thomet
2.7k12648
accept rate: 38%

1

Why, yes! It was exactly as you suspected, deleting the DPROJ files solved it. Now I also have my beloved Advantage package in XE6. Thank you kind sir, you are a gentleman and a scholar!

(06 Jun '14, 10:47) Overclock Yo...

Overclock, tell us how you got it to work!

Thanks!

link

answered 26 Jun '14, 20:43

David_in_WI's gravatar image

David_in_WI
56337
accept rate: 0%

I did nothing more than just delete the DPROJ files and open the dpk file. I believe I also changed some filenames, as mentioned in the article from Dr. Bob from Jed's post above. I might as well upload the package that can just be installed into XE6 with one click but I fear I may not redistribute the (altered) sources?

(30 Jun '14, 11:45) Overclock Yo...

I was able to get the component installed, and everything looks ok, but when I run the app it just immediately crashes. I haven't had time to try to figure out why, it may be a conflict with older ADS installation. First thing I want to check is the include file paths.

(30 Jun '14, 12:31) David_in_WI

I'm able to compile both the runtime and design time packages, but when I try to install the design time, I get "Access violation at address 5005F1D8 in module 'rtl200.bpl'. Read of address FFFFFFFD0,

(01 Jul '14, 10:25) planstone-bob

I worked on this another 90 min, my project loads with no errors, my TDBGrid's are populated, everything looks great. But when I run my app it just immediately crashes.

My files are

adsdxe6dstudio.bpl 83,968 bytes adsdxe6studio.bpl 557,568 bytes

(02 Jul '14, 12:24) David_in_WI

I got it to work! I created a ZIP file that contains all of the source files I used. This is the 32 bit version, my version of Windows 7 is 32 bit, so I have no need for 64 bit.

  1. If you are using an old XE5 or older project, you must edit the project with a text editor and change all references of XE3, XE4, XE5 to XE6.

  2. I think you should be able to just install my included package (adsdxe6dstudio.bpl) by skipping to step #7, but if that fails this is how I installed the component.....

(02 Jul '14, 13:12) David_in_WI

.3. I loaded the adsdxe6studio.dpk (note: the other project has an extra 'd' in it, make sure you load the correct project!). This project must be built FIRST. Just click BUILD ALL PROJECTS. Don't try to run it, it won't do anything.

.4. Then CLOSE ALL projects.

.5. Open project adsdxe6dstudio.dpk (this has the 'd' before 'studio')

.6. Click Build ALL projects, 2 new .bpl files should now exist

.7. To install the component, click COMPONENT, INSTALL PACKAGES. Then click ADD, and browse and add the adsdxe6dstudio.bpl (note the spelling)

(02 Jul '14, 13:14) David_in_WI
1

You should now see the package in the 'Design Packages' listing

The source files can be download from here

www.rcscoringpro.com/tracks/ads_xe6_32bit.zip

(02 Jul '14, 13:14) David_in_WI

@David, I've followed your steps, but get "The program can't start because AdsAdditionalDeisngers.dll is missing from your computer." Trying to get ADS installed in XE7.

(21 Nov '14, 05:07) AlanH
showing 5 of 8 show 3 more comments
Your answer to the original question.
If responding to a request for additional information, please edit the question or use the comment functionality.
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "Title")
  • image?![alt text](/path/img.jpg "Title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×133

Asked: 06 Jun '14, 05:52

Seen: 7,242 times

Last updated: 21 Nov '14, 05:07

Advantage Developer Zone Contact Us Privacy Policy Copyright Info


Powered by Advantage Database Server and OSQA
Disclaimer: Opinions expressed here are those of the poster and do not necessarily reflect the views of the company.