Navigation:  Advantage TDataSet Descendant > Managing Multiple Versions >

TDataSet Versions Supported

Advantage TDataSet Descendant

Managing Multiple Versions

Previous pageReturn to chapter overviewNext page

The TDataSet Switch utility supports versions 5.7 and greater of the TDataSet Descendant for Delphi 3-7 and version 7.1 and greater of the Advantage Delphi Components.

The utility supports the TDataSet for the following Delphi/C++Builder IDEs:

Delphi 3-7

C++ Builder 3-6

Borland Developer Studio 2006

Delphi/C++ Builder 2007, 2009, 2010

 

Note For Delphi/C++ Builder 2007 users: The Switch utility is not compatible with some versions of the 7.1 and 8.1 release of the Advantage Data Access Compontents (ADAC). Your version of the Advantage Delphi Components will need to be greater than 7.10.0.01 and 8.10.0.18, respectively to for the Switcher to switch to these versions.

 

Note For TDataSet versions prior to 7.1, see the section Custom TDataSet Versions